
Concept
One of the most important facets of a successful Autodesk® Vault implementation with Autodesk® Inventor® 
is the correct configuration and use of Inventor project files.  There are many  benefits to configuring your 
Vault for use as a single vault project.  The single vault project workflow eliminates  the complications of 
learning and managing multiple projects, simplifies file resolution by creating a more flexible environment, and 
promotes the re-use of design data rather than re-creation.

Single project file configuration provides:
Simplicity - With a single project, you use the same project file for every design.  You are no longer required • 
to swap projects for different datasets and you benefit from a single common location for all of your data.
Reduced Resolution Failures - Inventor can automatically search for any missing files throughout your entire • 
data set. This search capability greatly reduces the number of times you need to manually locate missing 
files and is compatible with Vault, which provides tools to quickly search and manage a large central file set.
Increased Design Re-use - Any data in the vault can be re-used in any assembly by using the Place From • 
Vault command. With this method, you do not have to ever worry about adding a library path or copying a 
file from another project.

Depending on how you have structured your Vault and configured your projects, it is possible that you may 
encounter some file resolution errors, and some work may be required to repair broken Inventor links, but 
these initial obstacles are typically outweighed by the ongoing benefits offered by this workflow.
Keeping this in mind, there are a couple of important steps to look at in order to leverage the single project 
functionality, starting with the creation of your new single project. 
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Singular Project Folder Structure
We will first look at a Vault structure where multiple projects (and multiple project files) are contained 
under a single folder called Designs.

Prerequisites
Before proceeding with the procedure below, the customer should have installed:

Autodesk Inventor 2009 SP1  or newer• 
ADMS 2009 or newer• 
Autodesk Vault 2009 or newer• 
Autodesk Vault 2009 Property Editing and Inventor file dependencies hotfix - TS1088248 • 

The customer should have also performed the following steps (in order of appearance):

Each client workstation should open Autodesk Inventor and navigate to Tools>Application Options>Save • 
tab to enable the “Prompt to save for re-computable updates” option.

All files should be checked into Vault• 

Notes on TS1088248    
http://images.autodesk.com/adsk/files/ts1088248.zip

This hotfix is designed to aid in the resolution of Inventor files modified via the following Vault operations:
Copy Design• 
Move file• 
Move Folder• 
Rename File• 
Rename Folder• 
Replace File• 

The fix applies to all file dependencies affected after the application of the hotfix. Files that have been 
affected by resolution errors prior to the installation of the hotfix will not be resolved and must be manually 
resolved.  

See the related article ‘Hotfix - Assemblies open and prompt to resolve files’ for a description on manually 
resolving files.

http://usa.autodesk.com/adsk/servlet/ps/item?siteID=123112&id=11817081&linkID=9242018 
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Create New Project File 
In the following example, we map the top level folder (“$”) to a local folder (“Work”).  Ideally we should 
configure the working folder for all users which will  simplify the Vault usage by creating a consistent local 
directory for everyone to work from.

To set the working folder, select Administration -> Tools in the Vault browser.   On the Files tab, click 1.	
Define to launch the Working Folder Options dialog.  Select  Enforce working folder for all clients and 
enter “C:\Work\” in the Client Working Folder field. 

Go to Inventor and select File -> Projects. Create a New Vault Project from the Wizard. 2.	

Click Next and enter “C:\Work\” in the Project (Workspace) Folder field.  3.	

The project file name “C:\Work\Designs.ipj” is displayed in the Project File to be created field. 

Click Next and skip adding any libraries by clicking the Finish button. 4.	
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After the project has been created, highlight the new “Designs” project file and double-click it to set it as 5.	
active.  
Now we must modify several folder paths.

Workspace – Expand the workspace path details using the details button on the bottom right of the • 
projects window. Highlight the workspace path “.” and set this to the folder containing your design 
files (relative path) “.\Designs\”.
Libraries – Select the libraries directory and add your library location as “C:\Work\Libraries\”. • 

NOTE: There are two ways in which your library may be set up – a single library folder under the Vault root 
with several sub-folders, or, conversely, there may be a number of library folders directly under the root 
directory of Vault.  Both methods are acceptable with perhaps the first, a single library folder under “$” 
proving the most flexible and simplest to manage in terms of moving and editing; as such, we will use that 
example in this document ($/Libraries/).  We will discuss library editing in the next section.

Content Center Files – Finally, expand  the Folder Options node and change the Content Center Files 
location to “C\Work\Content Center Files\”.  This location ensures that all users have a consistent content 
center store, complies with the enforced working folder setting, and provides better Vault performance for 
these library parts.

You now need to set the project file as current and map to Vault workspaces.6.	

NOTE: If you are not already logged into Vault through the Inventor add-in, go to Files > Autodesk Data 
Management Server > Log In and enter your user name and password.

Go to Files > Vault > Map Folders and select the Workspace as “$/Work”.  Map the libraries folder to “$/
Libraries” and map the Content Center Files as “$/Content Center Files”.  Click Save and Done.

Tip: To avoid issues with people changing the project file details, log into Vault as Administrator and check 
out the project file so no one else can check out or modify your project file.

NOTE: You must include ALL 
current top level folders in your 
project to avoid resolution errors 
during the project clean up, even 
if only temporarily by adding them 
as library paths for restructuring 
purposes. They will be removed 
again after the restructure is 
complete.
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Remove Redundant Project Files
With the new single project in place, it is best to remove the now redundant multiple projects living in the 
workspace sub-folders.

Log in as the administrator and perform a basic search command:
Search for *.ipj1.	
Highlight results2.	
Delete3.	
Do NOT remove the new project you have created4.	

You should now have a single project managing all Vault data.

Go to user’s workstations and get the latest project file.  Set the new project as active and open a sample 
assembly to test file resolution.

If you wish to test all file resolutions, move the entire vault to a local workspace and scan the entire dataset 
with Autodesk® Autoloader to check file resolution.  See more Autoloader information on loading a large 
dataset at http://mfgcommunity.autodesk.com/blogs/blog/view/5/Running_Multiple_instances/.

Find Duplicates Inside an Existing Vault 
Working inside of Inventor, there is an option to enforce unique file names per project.  Vault also offers the 
ability to enforce unique file names across an entire vault. The disadvantage of using Inventor to enforce 
unique file names is that you may have a number of individual file names in each project which are actually 
common across the vault.  This redundant naming can cause issues with file resolution once you combine 
everything into one project, so it’s a good idea to remove these duplicates.  Inventor will, by design, resolve 
and open the first file with the correct name and not continue to find subsequent versions which may or may 
not be the intended component. 

To get a list of duplicates, select Tools > Administration and then click Find Duplicates on the Files tab.

The Find Duplicates command produces a list of duplicates from which you can now create a report and 
work through to rename, replace, or remove files using the relevant Vault tools.

With the report in hand, you will need to check each file’s status and take the corresponding action.
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NOTE: To help with the resolution process, it may be useful to search for file duplicates using file name, date created, 
date modified, and file size. True duplicate files will have an identical file size in addition to the file name.

Rename – In a situation where two fundamentally different files exist with one name you will need to give one of 
these files a different name.  Using the rename wizard within Vault, you can be confident that the file links will be 
correctly repaired and can track this name change.  

NOTE: Where possible, renaming the file with the least number of file dependencies is preferable.

Replace – If you have reused a file by simply copying it into a new project and reusing it with the same name, you now 
have to consolidate this back to one single file. The first step in doing this is to launch the Replace wizard, with which 
you can select the secondary copy of the file and replace it with the original file in each of its use cases.  With only one 
file now being used (the second file should now have no Where Used links), you can remove the second copy.

Remove – Using the Delete command, you can remove any duplicate files no longer required because they have been 
replaced or are otherwise unused in the vault.  Deleting a file will remove the duplicate and all of its versions, and 
should only be done when you are confident the file is not in use or unique. 

Multiple Project Folder Structure
There is also a possibility that the vault has been structured in such a way that there is a number of Inventor project 
folders (workspaces) created in the root of your Vault.  These project folders will need to be reconfigured in order for a 
single project to work. There are two ways in which you can reconfigure project folders for a single project.

Option 1: Re-Loading Data
You can reorganize your data into a single project folder by simply reloading your data into the vault.

With this method, you are required to retrieve all your files from the vault and place them in a local working folder 
(C:\Work\Designs\). Then, by using Autoloader, you must reload these files into a new vault created in the Data 
Management Console.

See the Autoloader whitepaper for information on loading a large dataset to your Vault.  This method will allow 
you to set a single project file as described in the previous sections, but will remove all version history that would 
not be appropriate for use in a Autodesk® Vault Manufacturing (previously known as Autodesk® Productstream®) 
environment.

If version history is considered too important to lose, you may have to look at a second option.

Option 2: Moving Data
This option avoids reloading data but may cause future issues where large file movement in the vault can be 
problematic.  Please review the following section on moving files before you attempt this.

When moving data, you must create the new folders within Vault “$/Designs”, “$/Libraries” and “$/Content Center 
Files”.  Create the project as described above.

You can then begin to drag and drop each of your project folders to the “Designs” folder, creating the required 
structure. 
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Going Forward
To ensure optimum Vault performance going forward:

Ensure  that the Unique File Names flag remains in use so no new duplicates are added• 
Ensure all staff understand that one project file is used from this point forward• 
Ensure Administrator assigned working folder is in use for all designers• 
File move is not frequently used between folders, in particular libraries• 

Moving Files 
By having a project in the $ folder, you are now able to move files between libraries, or to and from the 
working folders to any other location in the vault.

Moving files is not ideal but may be unavoidable.  Moving files can reduce Vault performance and file 
retrieval; and it can also cause resolution issues if your project is not set correctly.

The first thing to consider with moving files is the order in which it is done. If you are moving a large 
number of files, including drawings (IDWs or DWGs), presentation files (IPNs), assemblies (IAMs) and 
parts (IPTs),  you should move them in the following order:

Drawings1.	
Presentation Files2.	
Assemblies3.	
Parts4.	

This order will reduce the amount of re-referencing required and reduce resolution failure.

Another consideration is the project file. We have discussed in previous sections how to set up a project 
in the top level folder ($) and remove any subsequent projects to ensure the new project is used for all 
future projects and clean up.

Editing Library Parts 
From time to time, users will still need to modify library parts involving either a physical change, in which 
case a file will need to be modified in the CAD application; or a property edit, such as the file name , part 
number, or a file location.  For each of these edits, there are different considerations to ensure that the 
file is edited correctly.

Edit File
In order to modify an Inventor file listed as a library file, a library edit project is required.  Ideally this 
project should be temporary, and the edits should be carried out either with full knowledge of the design 
team or, if possible, outside of working hours. The procedure to create this project is:

Create new project called “EditMyLibrary.ipj”, leaving the default workspace “.”1.	
Save the library project to “C:\Work\Libraries” (“C:\Work\Libraries\EditMyLibrary.ipj”)2.	
Do not add any library locations. Click OK to continue.3.	
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NOTE: Ideally, a single project to manage all of the libraries under a single location is preferable but in 
the case of multiple library folders at the top level, several projects may be required.  These should not be 
used by end users for any purpose  other than modifying library parts.

Map the workspace in your Vault and add this project file to the vault.4.	

Delete the library edit project file when completed. Do not retain it in the vault.5.	

NOTE: It may be worthwhile to keep a copy of the library project in a different state, perhaps in a zip 
file of the library workspace so when needed, users can get the latest version, unzip the project file, and 
reconfigure the files for re-use.

The reason for deleting or storing the library project with a zip extension is discussed in the following 
section.

 

Rename and Move Library Files
There are specific issues associated with Rename and Move that must be looked at. When  consolidating  
a single project vault, many of these errors will be eliminated.

Example 1 – Rename a file in the Library

If you rename a file in folder “Library 1” which 
has a parent assembly in that same folder and a 
project designed for editing library components  
(e.g.,  “Library.ipj”),  then this project will be 
used to resolve the reference rather than 
“Designs.ipj”,  which is the correct top level 
project.

In comparison, a library file with parents  that 
reside outside of the Library in a folder under 
the workspace will use the “Designs.ipj” to 
resolve the reference to these parents,  and will 
always resolve correctly on open in this project.

Generally file resolution errors in Inventor still 
should be overcome using the single master 
project but, ideally, the first situation will be 
avoided by removing the library editing project 
when it is not required.

Example 2 – Moving Files into and out of the 
library

If you were to move a file into or within the 
library folder with a parent also located in the 
library then the “Library.ipj” would be used to 
resolve the files in their new location rather 
than the Designs.ipj, which would typically be 
used to open the parents.

If this file’s parent resides within the 
Workspace folder path (or if no Library.ipj 
exists), then any move of this library file will 
utilize the “Designs.ipj” project file, ensuring 
that there are no resolution errors in the 
future.
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How to Repair Bad References 
When Vault operations affect child-parent relationships,  a new parent file version is created for the 
affected children.

For example, renaming Part 1 used in Assembly 1 to “Part 2”:
Creates Version 2 of Part 1, now called Part 2• 
Creates Version 2 of Assembly 1 which references Part 2• 

  

If the wrong project was used to resolve the file renaming, then when Inventor is opened, Version 2 of 
Assembly 1 will not automatically find Part 2, and the user is forced to manually resolve this.

By way of getting around this issue, Hotfix TS1088248 now provides details in the comments field of Part 
2 as to the project used to complete the operation. 

In a multi-project vault, this comment would allow you to locate the project used for file resolution 
and resolve the files correctly.  Once we have a single vault project however, this should resolve all files 
correctly regardless of location.  In this case, we can use the comment information to locate and remove 
the unwanted project, most likely located in one of the vault sub-folders, and simply continue to open the 
file using the single vault project file.

Conclusion
Despite the extra diligence required to ensure existing assemblies and drawings open correctly under the 
new master project, these procedures will help to alleviate your current resolution errors.  By revising 
the basics of your Inventor project usage and interaction with Autodesk Vault based on the procedures 
and suggestions in this document, your design team will avoid many ongoing issues associated with file 
resolution, simplify file management in Vault and the day to day use of Inventor, and facilitate greater 
design re-use. 

Learn More
The Vault family of products helps design, engineering, and manufacturing workgroups manage the 
Digital Prototyping process. Users can reduce time organizing files, avoid costly mistakes, and more 
efficiently release and revise designs. The revision process can be quickly deployed or tailored to unique 
requirements.  For more information about the complete Vault family of products, go to www.autodesk.
com/vaultfamily or contact an authorized Autodesk Reseller at www.autodesk.com/reseller.
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